Студопедия Главная Случайная страница Задать вопрос

Разделы: Автомобили Астрономия Биология География Дом и сад Другие языки Другое Информатика История Культура Литература Логика Математика Медицина Металлургия Механика Образование Охрана труда Педагогика Политика Право Психология Религия Риторика Социология Спорт Строительство Технология Туризм Физика Философия Финансы Химия Черчение Экология Экономика Электроника

ЭКОНОМИЧЕСКАЯ ТЕОРИЯ





 

В Excel имеется эффективный инструмент для решения задач оптимизации – программная надстройка Поиск решения. Установка этой надстройки производится через меню Сервис►Надстройки, после чего в диалоговом окне Надстройки необходимо пометить пункт Поиск решения и нажать кнопку ОК. После установки этой надстройки в меню Сервис появляется дополнительный пункт Поиск решения. Рассмотрим его использование для решения задач ЛП на примере 2.1.

Введем данные в электронную таблицу так, как это показано ниже.

Таблица 2.10

 

  A B C D E
Переменные x1 x2   Правые части ограничений
Значения        
Коэффициенты ограничений =B3*$B$2+C3*$C$2
=B4*$B$2+C4*$C$2
–1 =B5*$B$2+C5*$C$2
  =B6*$B$2+C6*$C$2
Целевая функция =B7*$B$2+C7*$C$2  

Для переменных x1 и x2 отведены ячейки B2 и C2. Эти ячейки называются изменяемыми ячейками. В эти ячейки ничего не заносится, и в результате решения задачи в них будут записаны оптимальные значения переменных. В ячейки D3–D6 вводятся формулы для вычисления левых частей ограничений, а в ячейку D7 – формула для вычисления целевой функции. Знаки доллара в формулах введены для того, чтобы формулы в ячейках D4–D7 можно было получить копированием формулы из ячейки D3.

 

 

Рис. 2.15

 

Затем в меню Сервис выбираем процедуру Поиск решения. В появившемся окне (рис. 2.15) устанавливаем целевую ячейку D7, выбираем вариант оптимизации (максимизация), вводим адреса изменяемых ячеек и ограничения. Для ввода ограничений используем кнопку Добавить. Кнопки Изменить и Удалить служат соответственно для изменения или удаления помеченного ограничения. Кнопка Предположить служит для автоматического выбора изменяемых ячеек. Далее нажимаем кнопку Параметры, и в появившемся окне устанавливаем флажки Линейная модель (в этом случае при решении задачи будет использоваться симплекс-метод) и Неотрицательные значения. Остальные значения можно оставить без изменения. Нажимаем кнопку ОК. Для решения задачи в окне Поиск решения нажимаем кнопку Выполнить. После нахождения решения появляется диалоговое окно для выбора типа отчета. Выбираем два типа: Результаты и Устойчивость, и нажимаем ОК. Первоначальная электронная таблица заполняется результатами, полученными при решении (табл. 2.11).

Таблица 2.11

 

  A B C D E
Переменные x1 x2   Правые части ограничений
Значения 3,3333 1,3333    
Коэффициенты ограничений
–1 –2
  1,3333
Целевая функция 12,667  

 

Отчеты появляются на отдельных листах книги Excel. Отчет Результаты состоит из трех таблиц и имеет следующий вид.

Таблицы 2.12

 

Целевая ячейка (Максимум)    
Ячейка Имя Исходно Результат
$D$7 Целевая функция 12,66666667

 

Изменяемые ячейки    
Ячейка Имя Исходно Результат
$B$2 Значения x1 3,333333333
$C$2 Значения x2 1,333333333

 

Ограничения        
Ячейка Имя Значение Формула Статус Разница
$D$3 Коэффициенты ограничений $D$3<=$E$3 связанное
$D$4   $D$4<=$E$4 связанное
$D$5   -2 $D$5<=$E$5 не связан.
$D$6   1,333333333 $D$6<=$E$6 не связан. 0,666666667

 

В первой из этих таблиц указано оптимальное значение целевой функции, во второй – значения переменных, в третьей – оптимальные расходы ресурсов, их статус и допустимое снижение запасов недефицитных ресурсов без изменения оптимального решения. Фактически вся эта информация содержится в итоговой таблице 2.11 (или легко извлекается из нее).

Отчет Устойчивость состоит из двух таблиц и имеет следующий вид:

Таблицы 2.13

 

Изменяемые ячейки          
Ячейка Имя Результ. значение Нормир. стоимость Целевой коэффициент Допустимое увеличение Допустимое уменьшение
$B$2 Значения x1 3,333333333
$C$2 Значения x2 1,333333333 0,5

 

Ограничения          
Ячейка Имя Результ. Теневая Ограничение Допустимое Допустимое
значение цена Правая часть увеличение уменьшение
$D$3 Коэффициенты ограничений 0,333333333
$D$4   1,333333333
$D$5   -2 1E+30
$D$6   1,33333333 1E+30 0,666666667

 

Первая из этих таблиц содержит диапазоны изменения коэффициентов целевой функции, в которых не происходит изменения оптимального решения. Во второй таблице приводятся теневые цены ресурсов и диапазоны изменения запасов каждого из ресурсов (при условии неизменности других ресурсов), в которых теневые цены остаются неизменными. Значения 1E+30, приведенные в таблице, означают возможность бесконечного увеличения правых частей соответствующих ограничений без изменения теневых цен.

При решении задач ЦЛП, в том числе и задач с булевыми переменными, с помощью программы Поиск решения, никаких дополнительных сложностей не возникает: нужно лишь при вводе ограничений ввести дополнительные ограничения – все или часть переменных принимают целые (или двоичные) значения. Для таких задач выводится только один тип отчета – отчет по результатам.

Решение транспортной задачи в Excel проиллюстрируем на примере 2.12. Введем данные в электронную таблицу так, как показано в таблице 2.14.

Таблица 2.14

 

  A B C D E F
  Потребители  
Поставщики Запасы поставщиков
Потребности потребителей  
          =СУММ(B7:E7)
          =СУММ(B8:E8)
          =СУММ(B9:E9)
  =СУММ(B7:B9) =СУММ(C7:C9) =СУММ(D7:D9) =СУММ(E7:E9) =СУММПРОИЗВ(B3:E5;B7:E9)
                   

 

В ячейки B3:F6 запишем исходные данные: в ячейках B3:E5 содержатся тарифы перевозок от соответствующего поставщика к соответствующему потребителю, в ячейках B6:E6 – потребности потребителей, а в ячейках F3:F5 – запасы поставщиков. Ячейки B7:E9 отведем под значения переменных – объемы перевозок от соответствующего поставщика к соответствующему потребителю, т. е. эти ячейки будут изменяемыми. В ячейках B10:E10 содержатся формулы, по которым подсчитывается общий объем груза, перевезенный данному потребителю, а в ячейках F7:F9 – объем груза, вывезенного от данного поставщика. В ячейке F10 содержится формула для целевой функции – суммарная стоимость всех перевозок.

Выполнив процедуру Поиск решения (указав в качестве цели минимизацию содержимого ячейки F10 и введя ограничения F7:F9 = F3:F5, B10:E10 = B6:E6), получим результат в виде таблицы 2.15.

Таблица 2.15

 

  A B C D E F
  Потребители  
Поставщики Запасы Поставщиков
Потребности потребителей  
 
 
 
 

 

 


[1] Существуют и другие универсальные методы решения ЗЛП. Например, метод разрешающих множителей, разработанный советским математиком Л. В. Канторовичем в 1939 г.

[2] Название ОЗЛП и КЗЛП не являются общепринятыми. В ряде работ основную задачу называют канонической, а каноническая не имеет специального названия.

[3] Целой частью числа a называется наибольшее целое число, не превосходящее a. Оно обозначается [a]. Например, [2,3]=2, а [–2,3]=-3. Дробной частью числа a называется разность между числом a и его целой частью. Она обозначается {a}. Таким образом, по определению, {a}=a–[a], т. е. a=[a]+{a}. Например, {2,3}=2,3 – 2=0,3,
а {–2,3}=–2,3–(–3)=0,7. Заметим, что из этих определений следует, что для всех a

ЭКОНОМИЧЕСКАЯ ТЕОРИЯ

Практикум

 

Владивосток

Издательство ВГУЭС

ББК 65.011

Э 40

Рецензенты: Ю.Д. Шмидт,д-р экон. наук, профессор, проректор Тихоокеанского государственного экономического университета

Д.К. Шевченко,д-р экон. наук, профессор Дальневосточного государственного технического рыбохозяйственного университета

В.А. Осипов,д-р экон. наук, профессор Владивостокского государственного университета экономики и сервиса

 

ЭКОНОМИЧЕСКАЯ ТЕОРИЯ : практикум [Текст] / под

Э 40 общ. ред. Е.В. Горбенковой. – Владивосток : Изд-во

ВГУЭС , 2011. – 272 с.

 

ISBN 978-5-9736-0193-5

 

Практикум представляет собой сборник практических задач и заданий, необходимых для успешного усвоения дисциплины «Экономическая теория». Составлен в соответствии с программой дисциплины, рассчитанной на студентов направлений бакалавриата «Менеджмент», «Коммерция», «Торговое дело», «Товароведение» и других неэкономических направлений, а также может быть использован в качестве базового задачника для студентов направления «Экономика», изучающих такие дисциплины, как «Микроэкономика» и «Макроэкономика». В практикум вошли все темы, включённые государственным образовательным стандартом в обязательный минимум содержания дисциплины «Экономическая теория».

Предназначен для студентов, магистрантов, преподавателей.

 

ББК 65.011

Авторский коллектив:

Гетман О.В.

Горбенкова Е.В., канд. экон. наук

Комиссарова В.В.

Лайчук О.В., канд. экон. наук

Николаева Л.А.,канд. экон. наук

ISBN 978-5-9736-0193-5 © Издательство Владивостокского

государственного университета

экономики и сервиса, 2011

 

СОДЕРЖАНИЕ

ВВЕДЕНИЕ.................. ....................................................................................... 3

Методические рекомендации ...............................................................................4






Дата добавления: 2014-11-10; просмотров: 343. Нарушение авторских прав

Studopedia.info - Студопедия - 2014-2017 год . (0.115 сек.) русская версия | украинская версия