Студопедия Главная Случайная страница Обратная связь

Разделы: Автомобили Астрономия Биология География Дом и сад Другие языки Другое Информатика История Культура Литература Логика Математика Медицина Металлургия Механика Образование Охрана труда Педагогика Политика Право Психология Религия Риторика Социология Спорт Строительство Технология Туризм Физика Философия Финансы Химия Черчение Экология Экономика Электроника

Использование Мастера функций





MS Excel содержит 228 встроенных функций. Простейший способ получения полной информации о любой из них заключается в использовании меню справки (?).Для удобства функции в Excel разбиты по категориям (математические, финансовые, статистические и т.д.).

Обращение к каждой функции состоит из двух частей: имени функции и аргументов в круглых скобках. Аргументы функции могут быть следующих типов:

1)числовые константы, например, функция ПРОИЗВЕД(2;3) вычисляет произведение чисел 2 и 3, т.е. 2·3.

2)ссылки на ячейки и блоки ячеек (функция ПРОИЗВЕД (А1;С1:СЗ) вычисляет произведение содержимого ячеек А1,С1,С2иС3, т.е.А1·С1·С2·СЗ.

3) текстовые константы (заключенные в кавычки).

4) логические значения.

5) массивы.

6) имена ссылок, например, если ячейке А10 присвоить имя СУММА (последовательность команд Вставка, Имя, Определить...), а блоку ячеек В10:Е10 - имя ИТОГИ , то допустима следующая запись: =СУММ(СУММА; ИТОГИ).

7) смешанные аргументы, например, =СРЗНАЧ (Группа;АЗ;5*3)

Формулы, содержащие функции, можно вводить непосредственно в ячейку, в строку формул или создавать с помощью Мастера функций. Для вызова Мастера функций необходимо выбрать команду Функция в меню Вставка или нажать кнопку Мастер функций (значок fx). B открывшемся диалоговом окне выберите категорию и имя функции, затем в поля с соответствующими подсказками введите аргументы. После нажатия кнопки Закончить готовая функция появится в строке формул

Пример 1. Вычислить значение функции у = ех · sin(x) для -1=< х <=1 c с шагом Δх=0,2. Определить количество отрицательных у.

Заполним столбец Азначениями аргумента функции. Чтобы не вводить их вручную , применим следующий прием. Введите в ячейку А1 начальное значения аргумента -1. В меню Правка выберите команду Заполнить, затем Прогрессия и в открывшемся диалоговом окне укажите предельное значение(1),шаг(0.2) и направление (По столбцам). После нажатия кнопки ОКв столбце Абудут введены все значения аргумента . В ячейку В1введите формулу: =exp(А1)* sin(A1). Размножьте эту формулу на остальные ячейки столбца В, ухватив левой мышью черный квадратик в правом нижнем углу рамки выделенной ячейки В1 и протащив рамку до конца изменения аргумента . В итоге будут вычислены соответствующие значения функции во всех ячейках столбца В.

Для определения количества отрицательных у в ячейку С1введите формулу =СЧЕТЕСЛИ (В 1: В 11; <0). В результате в ячейке С1 будет вычислено количество отрицательных значений в ячейках В1:В11(т.е. у).

Принцип действия большинства логических функций Excel заключается в проверке некоторого условия и выполнения в зависимости от него тех или иных действий. Так, функция ЕСЛИ выполняет проверку условия, задаваемого первым аргументом логического выражения: ЕСЛИ (логическое 1; значение_да; значение нет)и возвращает значение да, если условие выполнено (ИСТИНА), и значение нет - в противном случае (ЛОЖЬ).

Например:

1)=ЕСЛИ(В6<10;5; 10). Если значение в ячейке В6<10, то функция вернет результат 5, иначе -10.

2)=ЕСЛИ(В4>80;"Сданы";"Не сданы"). Если значение В4>80, то в ячейке с приведенной формулой будет записано "Сданы", иначе - "Не сданы".

3)=ЕСЛИ(СУММ(А1:А10)>0; СУММ(В1:В10);0).Если сумма значений в столбце А1:А10 >0, то в ячейке, содержащей эту формулу вычислится сумма значений в столбце В1:В10, иначе – запишется 0.

Дополнительные логические функции:

=И(логическое выражение 1; логическое выражение 2;...) – возвращает значение ИСТИНА, если все аргументы истинны, и ЛОЖЬ, если хотя бы один аргумент – ЛОЖЬ.

Например, для =ЕСЛИ(СУММ(А1:А10)>0; И; СУММ(В1:В10)>0; СУММ(А1:В10);0).Если суммы и в столбце А1:А10 и в столбце В1:В10 положительны , то вычислить сумму значений в ячейках А1:В10, иначе - 0.

Аналогично используются:

=ИЛИ(логическое 1;логическое 2;...) – возвращает значение ИСТИНА, если хотя бы один аргумент является – ИСТИНА.

=НЕ(флаг) – меняет значение ИСТИНА на ЛОЖЬ и наоборот.

 







Дата добавления: 2014-11-10; просмотров: 352. Нарушение авторских прав; Мы поможем в написании вашей работы!

Studopedia.info - Студопедия - 2014-2022 год . (0.017 сек.) русская версия | украинская версия